一、DeviceA-M-LAG-Mater配置
1、M-LAG 系统配置。
#
m-lag mad exclude interface GigabitEthernet1/0/7
m-lag mad exclude interface Vlan-interface100
m-lag mad exclude interface Vlan-interface101
m-lag system-mac 0002-0002-0002
m-lag system-number 1
m-lag system-priority 200
m-lag keepalive interval 500
m-lag keepalive ip destination 100.100.100.1 source 100.100.100.2
#
2、keeplive路由配置。
#
interface GigabitEthernet1/0/7
port link-mode route
combo enable fiber
ip address 100.100.100.2 255.255.255.0
#
3、peek-link链路配置。
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
#
4、将接口加入到对应的聚合组。
#
interface Ten-GigabitEthernet1/0/51
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable fiber
port link-aggregation group 125
#
interface Ten-GigabitEthernet1/0/52
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable fiber
port link-aggregation group 125
#
5、将链路聚合组加入M-LAG组中。
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
port m-lag peer-link 1
#
6、创建链路聚合组跟上行链路和下连链路相连。
#
interface Bridge-Aggregation100
port link-type trunk
port trunk permit vlan 1 100
link-aggregation mode dynamic
#
#
interface Bridge-Aggregation101
port link-type trunk
port trunk permit vlan 1 101
link-aggregation mode dynamic
#
7、将对应的接口加入到对应的链路聚合组。
#
interface GigabitEthernet1/0/6
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100
combo enable fiber
port link-aggregation group 100
#
interface GigabitEthernet1/0/8
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 101
combo enable fiber
port link-aggregation group 101
#
8、将对应的组加入到M-LAG组中去
#
interface Bridge-Aggregation101
port link-type trunk
port trunk permit vlan 1 101
link-aggregation mode dynamic
port m-lag group 2
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
port m-lag peer-link 1
#
9、创建vlan三层接口,给对应的接口配置对应的地址
#
vlan 100 to 101#
interface Vlan-interface100
ip address 10.1.1.1 255.255.255.0
#
interface Vlan-interface101
ip address 20.1.1.1 255.255.255.0
#
10、配置 Vlan-interface100 和 Vlan-interface101 接口为 M-LAG 保留接口
m-lag mad exclude interface Vlan-interface100
m-lag mad exclude interface Vlan-interface101
11、配置OSPF
#
ospf 1
import-route direct
area 0.0.0.0
network 10.1.1.0 0.0.0.255
network 20.1.1.0 0.0.0.255#
12、VRRP配置,设定优先级。
#
interface Vlan-interface100
ip address 10.1.1.1 255.255.255.0
vrrp vrid 1 virtual-ip 10.1.1.100
vrrp vrid 1 priority 200
#
interface Vlan-interface101
ip address 20.1.1.1 255.255.255.0
vrrp vrid 2 virtual-ip 20.1.1.100
vrrp vrid 2 priority 200
#
二、DeviceB-M-LAG-Backup配置
1、M-LAG 系统配置。
#
m-lag mad exclude interface GigabitEthernet1/0/7
m-lag mad exclude interface Vlan-interface100
m-lag mad exclude interface Vlan-interface101
m-lag system-mac 0002-0002-0002
m-lag system-number 1
m-lag system-priority 200
m-lag keepalive interval 500
m-lag keepalive ip destination 100.100.100.2 source 100.100.100.1
#
2、keeplive路由配置。
#
interface GigabitEthernet1/0/7
port link-mode route
combo enable fiber
ip address 100.100.100.1 255.255.255.0
#
3、peek-link链路配置。
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
#
4、将接口加入到对应的聚合组。
#
interface Ten-GigabitEthernet1/0/51
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable fiber
port link-aggregation group 125
#
interface Ten-GigabitEthernet1/0/52
port link-mode bridge
port link-type trunk
port trunk permit vlan all
combo enable fiber
port link-aggregation group 125
#
5、将链路聚合组加入M-LAG组中。
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
port m-lag peer-link 1
#
6、创建链路聚合组跟上行链路和下连链路相连。
#
interface Bridge-Aggregation100
port link-type trunk
port trunk permit vlan 1 100
link-aggregation mode dynamic
#
#
interface Bridge-Aggregation101
port link-type trunk
port trunk permit vlan 1 101
link-aggregation mode dynamic
#
7、将对应的接口加入到对应的链路聚合组。
#
interface GigabitEthernet1/0/6
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100
combo enable fiber
port link-aggregation group 100
#
interface GigabitEthernet1/0/8
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 101
combo enable fiber
port link-aggregation group 101
#
8、将对应的组加入到M-LAG组中去
#
interface Bridge-Aggregation101
port link-type trunk
port trunk permit vlan 1 101
link-aggregation mode dynamic
port m-lag group 2
#
interface Bridge-Aggregation125
description peek-link
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
port m-lag peer-link 1
#
9、创建vlan三层接口,给对应的接口配置对应的地址
#
vlan 100 to 101#
interface Vlan-interface100
ip address 10.1.1.2 255.255.255.0
#
interface Vlan-interface101
ip address 20.1.1.2 255.255.255.0
#
10、配置 Vlan-interface100 和 Vlan-interface101 接口为 M-LAG 保留接口
m-lag mad exclude interface Vlan-interface100
m-lag mad exclude interface Vlan-interface101
11、配置OSPF
#
ospf 1
import-route direct
area 0.0.0.0
network 10.1.1.0 0.0.0.255
network 20.1.1.0 0.0.0.255#
12、VRRP配置,设定优先级。
#
interface Vlan-interface100
ip address 10.1.1.1 255.255.255.0
vrrp vrid 1 virtual-ip 10.1.1.100
#
interface Vlan-interface101
ip address 20.1.1.1 255.255.255.0
vrrp vrid 2 virtual-ip 20.1.1.100
#
三、DeviceC配置
1、链路聚合
#
interface Bridge-Aggregation100
description 100
port link-type trunk
port trunk permit vlan 1 100
link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface100
ip address 10.1.1.3 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100
combo enable fiber
port link-aggregation group 100
#
interface GigabitEthernet1/0/2
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100
combo enable fiber
port link-aggregation group 100
#
2、OSPF
#
ospf 1
import-route direct
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
三、DeviceD配置
1、链路聚合
#
interface Bridge-Aggregation101
description juhezu101
port link-type trunk
port trunk permit vlan 1 101
link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface101
description C地址
ip address 20.1.1.3 255.255.255.0
#
interface GigabitEthernet1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 101
combo enable fiber
port link-aggregation group 101
#
interface GigabitEthernet1/0/4
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 101
combo enable fiber
port link-aggregation group 101
#
2、OSPF
#
ospf 1
import-route direct
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
四、测试
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]display m-lag verbose
Flags: A -- Home_Gateway, B -- Neighbor_Gateway, C -- Other_Gateway,D -- PeerLink_Activity, E -- DRCP_Timeout, F -- Gateway_Sync,G -- Port_Sync, H -- ExpiredPeer-link interface/Peer-link interface ID: BAGG125/1
State: UP
Cause: -
Local DRCP flags/Peer DRCP flags: ABDFG/ABDFG
Local Selected ports (index): XGE1/0/51 (52), XGE1/0/52 (53)
Peer Selected ports indexes: 52, 53
Reserved VLANs: -M-LAG interface/M-LAG group ID: BAGG100/1
Local M-LAG interface state: UP
Peer M-LAG interface state: DOWN
M-LAG group state: UP
Local M-LAG interface down cause: -
Remaining M-LAG DOWN time: -
Local M-LAG interface LACP MAC: Config=N/A, Effective=0002-0002-0002
Peer M-LAG interface LACP MAC: Config=N/A, Effective=N/A
Local M-LAG interface LACP priority: Config=32768, Effective=200
Peer M-LAG interface LACP priority: Config=N/A, Effective=N/A
Local DRCP flags/Peer DRCP flags: ABDFG/ABDFG
Local Selected ports (index): GE1/0/6 (7)
Peer Selected ports indexes: 7M-LAG interface/M-LAG group ID: BAGG101/2
Local M-LAG interface state: UP
Peer M-LAG interface state: DOWN
M-LAG group state: UP
Local M-LAG interface down cause: -
Remaining M-LAG DOWN time: -
Local M-LAG interface LACP MAC: Config=N/A, Effective=0002-0002-0002
Peer M-LAG interface LACP MAC: Config=N/A, Effective=N/A
Local M-LAG interface LACP priority: Config=32768, Effective=200
Peer M-LAG interface LACP priority: Config=N/A, Effective=N/A
Local DRCP flags/Peer DRCP flags: ABDFG/ABDFG
Local Selected ports (index): GE1/0/8 (9)
Peer Selected ports indexes: 9
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]display ospf lsdb ase 10.1.1.0 OSPF Process 1 with Router ID 100.100.100.2Link State DatabaseType : ExternalLS ID : 10.1.1.0Adv Rtr : 100.100.100.2LS age : 548Len : 36Options : O E Seq# : 80000003Checksum : 0x282bNet mask : 255.255.255.0MTID 0 Metric : 1E Type : 2Forwarding Address: 0.0.0.0Tag : 1Type : ExternalLS ID : 10.1.1.0Adv Rtr : 10.1.1.3LS age : 389Len : 36Options : O E Seq# : 80000001Checksum : 0x264fNet mask : 255.255.255.0MTID 0 Metric : 1E Type : 2Forwarding Address: 0.0.0.0Tag : 1Type : ExternalLS ID : 10.1.1.0Adv Rtr : 100.100.100.1LS age : 22Len : 36Options : O E Seq# : 80000003Checksum : 0x2e26Net mask : 255.255.255.0MTID 0 Metric : 1E Type : 2Forwarding Address: 0.0.0.0Tag : 1
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]display ospf verbose OSPF Process 1 with Router ID 100.100.100.2OSPF Protocol InformationRouterID: 100.100.100.2 Router type: ASBR Route tag: 0 Multi-VPN-Instance is not enabledExt-community type: Domain ID 0x5, Route Type 0x306, Router ID 0x107Domain ID: 0.0.0.0Opaque capable Isolation: DisabledISPF is enabled SPF-schedule-interval: 5 50 200LSA generation interval: 5 50 200LSA arrival interval: 1000Transmit pacing: Interval: 20 Count: 3Default ASE parameters: Metric: 1 Tag: 1 Type: 2Route preference: 10ASE route preference: 150SPF calculation count: 14 RFC 1583 compatibleGraceful restart interval: 120SNMP trap rate limit interval: 10 Count: 7Area count: 1 NSSA area count: 0 Normal areas with up interfaces: 1NSSA areas with up interfaces: 0Up interfaces: 2ExChange/Loading neighbors: 0Full neighbors: 4Area0 full neighbors: 4Calculation trigger type: N/ACurrent calculation type: N/ACurrent calculation phase: N/AProcess reset state: N/ACurrent reset type: N/ANext reset type: N/AReset prepare message replied: -/-/-/-Reset process message replied: -/-/-/-Reset phase of module:M-N/A, P-N/A, L-N/A, C-N/A, R-N/AArea: 0.0.0.0 (MPLS TE not enabled)Authentication type: None Area flag: NormalSPF scheduled count: 10 ExChange/Loading neighbors: 0Up interfaces: 2Interface: 10.1.1.1 (Vlan-interface100)Cost: 1 State: DR Type: Broadcast MTU: 1500 Cost source: DefaultPriority: 1Designated router: 10.1.1.1Backup designated router: 10.1.1.2Timers: Hello 10, Dead 40, Poll 40, Retransmit 5, Transmit Delay 1FRR backup: Enabled Enabled by network configurationInterface: 20.1.1.1 (Vlan-interface101)Cost: 1 State: DR Type: Broadcast MTU: 1500 Cost source: DefaultPriority: 1Designated router: 20.1.1.1Backup designated router: 20.1.1.2Timers: Hello 10, Dead 40, Poll 40, Retransmit 5, Transmit Delay 1FRR backup: Enabled Enabled by network configuration
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]display link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Port: A -- Auto port, M -- Management port, R -- Reference port
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation, D -- Synchronization, E -- Collecting, F -- Distributing, G -- Defaulted, H -- Expired Aggregate Interface: Bridge-Aggregation100
Creation Mode: Manual
Aggregation Mode: Dynamic
Loadsharing Type: Shar
Management VLANs: None
System ID: 0xc8, 0002-0002-0002
Local: Port Status Priority Index Oper-Key FlagGE1/0/6(R) S 32768 16386 40001 {ACDEF}
Remote: Actor Priority Index Oper-Key SystemID Flag GE1/0/6 32768 1 1 0x8000, 4608-9a44-0100 {ACDEF}Aggregate Interface: Bridge-Aggregation101
Creation Mode: Manual
Aggregation Mode: Dynamic
Loadsharing Type: Shar
Management VLANs: None
System ID: 0xc8, 0002-0002-0002
Local: Port Status Priority Index Oper-Key FlagGE1/0/8 U 32768 16387 40002 {AC}
Remote: Actor Priority Index Oper-Key SystemID Flag GE1/0/8 32768 1 1 0x8000, 4608-b060-0400 {AEF}Aggregate Interface: Bridge-Aggregation125
Creation Mode: Manual
Aggregation Mode: Dynamic
Loadsharing Type: Shar
Management VLANs: None
System ID: 0x8000, 4608-a246-0200
Local: Port Status Priority Index Oper-Key FlagXGE1/0/51(R) S 32768 1 1 {ACDEF}XGE1/0/52 S 32768 4 1 {ACDEF}
Remote: Actor Priority Index Oper-Key SystemID Flag XGE1/0/51 32768 1 1 0x8000, 4608-aaeb-0300 {ACDEF}XGE1/0/52 32768 4 1 0x8000, 4608-aaeb-0300 {ACDEF}
[DeviceA-M-LAG-Mater-Bridge-Aggregation100]
五、参考文献
- 50 IRF检测MAD-BFD-CSDN博客
- 图解IRF_irf配置-CSDN博客
- 华三虚拟化技术-IRF【多台设备如何操作?】_华三交换机如何做虚拟化-CSDN博客
- IRF拆除_删除irf配置-CSDN博客
- 初步认识OSPF的大致内容(第三课)_路由 directly connected-CSDN博客
- OSPF工作原理与配置详解-CSDN博客
- OSPFV3 华为_华为 vsi ospf-CSDN博客
- 74 华为OSPFV3&OSPFV2_华为防火墙配置ospfv3-CSDN博客
- 73 OSPF图解LSA(华三)_华三查看lsa-CSDN博客
- 71 OSPF多区域实验(华三)-CSDN博客
- RBM远程备份组-CSDN博客
- ②VRRP+RBM(FW/IPS)主备联动_rbm+vrrp-CSDN博客
- ⑧RBM(主备/主主)-二层部署案例_rbm双活技术部署方案-CSDN博客
- 16 华三数据中心最流行的技术 M-LAG_华三mlag-CSDN博客
- 17 M-LAG 配置思路_华为mlag配置-CSDN博客
- ⑨数据中心-M-LAG技术配置-CSDN博客
- ⑩数据中心M-LAG 实战-CSDN博客
- 12 华三的二层链路聚合_h3c 2层交换 链路聚合 没有interface bridge-aggregation-CSDN博客
- 15 华三华为链路聚合综述_链路聚合成员端口状态-CSDN博客
- 07 STP RSTP MSTP 链路聚合-CSDN博客
- 35 解决单条链路故障问题-华三链路聚合_blade-aggregation-CSDN博客
- 38 IRF+链路聚合+ACL+NAT组网架构_irf和nat-CSDN博客
- Vlan技术实操(第四课)-CSDN博客
- 网络技术Vlan技术&STP(第一课)_stpbqvn-CSDN博客
- 19 QinQ技术(Vlan两层封装)_qinq是什么意思-CSDN博客
- 32 华三vlan案例+STP-CSDN博客
- ACL 访问控制 过滤数据 维护网络安全(第七课)_二层acl过滤-CSDN博客
- 41 QOS技术(服务质量)-CSDN博客
- VRRP2/VRRP3_查看vrrp状态-CSDN博客
- 92 华为VRRP 理论-CSDN博客
- 91 VRRP负载局衡+主备切块 V2-CSDN博客
- 91 VRRP负载局衡+主备切块 V2-CSDN博客
- 90 VRRP 负载局衡 V2/V3_vrrp weight reduced-CSDN博客
- 89 多个VRRP组V2/V3-CSDN博客
- 88 VRRP 单臂 V2/V3-CSDN博客
- 87 VRRPV2/V3 综合技术实操_vrrp v3-CSDN博客
- VRRP DHCP ACL NAT 网络核心路由技术综述 (第十课)_dhcp核心技术-CSDN博客
简单的汇总一下上面的案例要用到技术,参考上面文章又可以了。